Reply To: Dollarone's let's play QfG! (spoilers)

Home Forums Previous Months 07 – August 2017: Quest for Glory Dollarone's let's play QfG! (spoilers) Reply To: Dollarone's let's play QfG! (spoilers)


Right, we start in a town, infront of a lazy Sheriff and and ogre with a… yo-yo?

also his name is “Otto van Goon”. Right.

I explore the town. At some point I find a shop that sells cupcakes. I try to order one. The game tells me “you will not need to use the word cupcake in this game”. Well, why did you include it then!!!

I throw some silver at a beggar in an alley which means I don’t have enough to drink the infamous Dragon’s Breath death-drink that the manual suggest you try (it does suggest to save before tho).

I buy some carrots, and consider the toaster in the magic shop. They also have spells for sale, ooh! As a Magic User I go straight for “Flame Dart” but it is too expensive, so I buy “Open” instead. Atleast I can open locks like a thief now, right?

I find the guild hall and register myself as an adventurer, woohoo! There’s a(nother) sleeping person here, (the game seems to put people to sleep to avoid having too many discussions) and you can wake this one up! Alas he soon falls asleep again.

There’s a bunch of quests on the board like a true D&D-game, and I note them all down.

I venture outside and decide to try my look in the forest. Wait, do I have a weapon? Ah yes I have a dagger, standard mage-style.

Soon my path is cut off by an avalanche! Ooh interesting! I try to look closer at it but the game fobs me off with “Nothing interesting here”.

I gain access to the healer’s hut and learn about her wares. I also ask about the quests that were mentioned in the Guild Hall. I feel like I’m a very successful adventurer so far. I exit and continue exploring.

Soon after I get attacked by an effing dinosaur who promptly eats me alive. How do you attack? I try “attack” and “fight” which gets the response “go ahead”.

By random keyboard-mashing it turns out its the up-key. OK. Reload.

I run around the whole forest, elaborately creating a map as I go along. I set a fox free from a trap, I run away from an ogre, I see a white walker who just blocks my way, and I find an “Antwerp” who I still don’t know anything about. Is it an enemy? A person? Perhaps a small dutch town personified?

I get some more quests from talking trees and skulls, head back to the inn, get another quest, and go to sleep after a nice dinner.

Next time I’ll try to actually do a quest…